いろんなこと
いろんなことやってます
スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
FlashPlayerのバージョンアップ(半分未解決)
メインで使ってるUbuntu9.04のマシンでYouTubeとかニコニコが見られないのです。
でもとりあえずYouTubeではポップアップ機能を使ったり、FireFoxの DownloadHelper というアドオンでダウンロードしてなんとか見れていたので良しとしていました。
ところが最近ダウンロードも出来なくなり、ポップアップ機能も無くなったみたいでまったく見ることが出来なくなってしまったので、またまた重い腰を上げて対処することにしました。

対象マシンは
OSがUbuntu9.04の普通のPCで、ブラウザはFirefox3.0.18です。


まあ、見られない原因は単純にFlashPlayerのバージョンが古いせいですね。
ここのサイトからプラグインを落として来ます。
自分の場合はなぜかUbuntu用のでインストール出来ませんでした。
なので、Linux用.tar.gzファイルっていうのを落とします。
このファイルを展開すると libflashplayer.so が取り出せます。
これを任意の場所に保存すれば良いはずです。

どこだ?

一生懸命探した結果、どうやら /usr/lib/mozilla/plugins にプラグインを入れれば良いらしい。
とりあえずこのディレクトリに libflashplayer.so を入れて Firefox を再起動するとニコニコを見ることができました。よしよし。

んで、現状は、
/usr/lib/mozilla/plugins/flashplugin-alternative.so -> /etc/alternatives/mozilla-flashplugin
のリンク先の
/etc/alternatives/mozilla-flashplugin -> /usr/lib/swfdec-mozilla/libswfdecmozilla.so
のリンク先の
/usr/lib/swfdec-mozilla/libswfdecmozilla.so
が古いバージョンの FlashPlayer らしい。

なので、
/usr/lib/swfdec-mozilla/ に libflashplayer.so を入れて /etc/alternatives/mozilla-flashplugin のリンク先に変更すると良いと思われます。

sudo rm /etc/alternatives/mozilla-flashplugin
sudo ln -s /usr/lib/swfdec-mozilla/libflashplayer.so /etc/alternatives/mozilla-flashplugin


一度削除してからリンク作成。

同ディレクトリの下記ファイルも、リンク先が libswfdecmozilla.so なので同様に変更します。
firefox-flashplugin
iceape-flashplugin
iceweasel-flashplugin
midbrowser-flashplugin
xulrunner-addons-flashplugin
xulrunner-flashplugin


これでニコニコは見ることが出来ました。しかし、YouTubeは"An error occurred,please try again later."と出て再生してくれません。
まだ他に修正する箇所があるのかな?
現時点ではまだ不明。
スポンサーサイト
コメント
コメント
コメントの投稿
URL:
本文:
パスワード:
非公開コメント: 管理者にだけ表示を許可する
 
トラックバック
トラックバック URL
トラックバック
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。